Page d'accueil de Aeropassion
Partenaires du site :
Envoyé par max 
max
Problème étonnant avec ma mm2001
mercredi 7 avril 2010 10:48
bonjour a tous

actuellement je finalise mon fil chaud a commande numérique , mais est apparu un phénomène bizzar lors des essais de ma carte sur la machine.
En effet, au début tout fonctionnait bien les moteurs, la reconnaissance du pourcentage de chauffe ect... Mais, hier au soir un des moteur s'arrête de fonctionner et commence à frétiller sans tourner. Je me dis alors que c'est peut être la nappe de fil ou un faux contact , je vérifie toutes mes soudures entre le pic et la nappe de fil résultat: RIEN .
Alors, le problème pourrait provenir de l'ULN , j'intervertis deux ULN et le problème persiste.
La, ça commence à être ennuyeux. je vais voir sur internet je ne trouve rien. Mais mon problème est bel et bien la.

Ce matin lorsque je me repenche sur la carte , premier essais ca marche YAHOOOO , deuxième essai ca ne marche plus.....
alors ce que j'ai essayer, c'est d'enlever l'uln et de vérifier les ordre venant du PIC avec un multimètre et en effet , deux des quatre pattes du pic ne commutent pas et restent à 5V.

Ma question, est ce que mon PIC est mort ou y-aurait-il une raison à son fonctionnement par intermittences?
y a t-il autre chose que je doive vérifier?

Merci d'avance
Max
Re: Problème étonnant avec ma mm2001
mercredi 7 avril 2010 21:46
Bonjour.

J'ai un fonctionnement bizarre sur ma MM2001.
J'en parle dans ces 2 discussions cherche les messages de cyril..
http://www.aeropassion.net/forums/read.php?5,2084,3115,quote=1
http://www.aeropassion.net/forums/read.php?5,2693
Au début je ne comprenais pas pourquoi un coup ça marchait et ensuite ça ne marchait plus.
Peut être est ce le même problème essaie en démarrant comme je le décrit.
bye a+
max
Re: Problème étonnant avec ma mm2001
jeudi 8 avril 2010 10:42
bonjour

je pense que mon problème vient réellement du pic, j'avais lu que certains pic se déprogrammaient sans raison, hier après avoir continué mes tests , d'un coup plus rien ne fonctionnait et depuis toujours rien... De ce fait j'ai commandé un nouveau pic au cas ou le mien serait définitivement mort et je demanderais à ce que l'on essaye de me reprogrammer les deux. (si je ne me fait pas un programmateur avant)
Pour l'instant je cherche un programmateur fiable j'ai déjà trouvé celui la
http://www.tavernier-c.com/programmateur_de_pic.htm
mais il faut que je refasse le typon pour pouvoir adapter à un db25 la prise et pouvoir graver mon circuit à l'anglaise

si quelqu'un a un adaptateur à me proposer je suis preneur tant que cela fait appel à des compostants simples.
ps: les liens vers les programmateur qui sont dans les sujet que tu m'a donné sont pour la plupart morts dommage

merci et je tiendrais au courant de l'avancement
Re: Problème étonnant avec ma mm2001
jeudi 8 avril 2010 21:09
Bonjour.

Je pense moi aussi que mon problème vient du pic mais j'ai essayer avec 3 pic 16F874A et 3 pic 16F877A et j'ai le même problème avec les 6 pics (ce sont tous des A donc mon problème viens peut être de là).
J'ai l'impression que ça viens de ma façon de le programmer mais bon comme ça marche comme ça donc j'ai arrêté de chercher.

Essaie cette manip si tu as le temps et tiens moi informer s'il te plais.

1 - allumage PC et carte avec sur la mm2001 moteur off, chauffe manuel et off
2 - action sur le reset de la mm2001
3 - déplacement positif de x1 dans jedicut
4 - moteur on sur mm2001
5 - re- déplacement positif de x1 dans jedicut (la le moteur x1 fonctionne)
6 - déplacement positif de y1 (y1 se déplace)
7 - maintenant tout fonctionne correctement.

Si je ne fais pas ça x2 et y2 fonctionnent mais dès que x1 est actionné la mm2001 plante et si le premier déplacement de y1 est négatif pareil la mm2001 plante.

J'ai aussi quelque fois un soucis avec la chauffe entre le passage du mode manuel a pc.

J'ai constaté ceci :
Je ne me rappelle plus quelle est la pins, mais si j'envoie un signal sur la pins du pic correspondant au sens de rotaion de X1 (si je me rappel bien), j'ai le pic qui plante. J'ai croisé les cables pour voir si ça viend du signal ou du pic et ça viend bien du pic.
Je ne sais pas si c'est un problème du au programme qui n'est pas compatible avec les 16F87*A ou si ça viend d'un réglage du programmateur lorsque je le programme.

bye a+ et bon courage
max
Re: Problème étonnant avec ma mm2001
vendredi 9 avril 2010 12:22
alors pour l'instant ne je peux rien essayer car j'ai un plantage total de ma carte , ni le reset ne fonctionne ni aucun bouton je ne peux rien faire du tout , de ce fait j'attends mon nouveau pic que je ferais programmer mais ceci ne seras surement pas effectif avant 2 semaines voir 3 (vacances obligent grinning smiley )

merci beaucoup je te tiendrais au courant quand ma carte sera de nouveau opérationnelle
tweety_pie
Re: Problème étonnant avec ma mm2001
vendredi 9 avril 2010 16:32
Salut

J'ai exactement le meme probleme que toi.

Après avoir grillé un ULN en faisant masse (boulet confused smiley )
Après avoir changer mon PIC qui me semblai comme toi defectueux

J'ai prit mon osciloscope et j'ai regarder l'ensemble du montage et je suis remonter jusqu'au port // du PC
D'apres mon diagnostique c'est le port du PC qui est mort. je ne recois plus ren sur les Pin de sortie

Pour le moment de vais remonter un autre PC mais j'ai pas encore eu le temps
Je sais pas si on peux griller le port // du PC avec un retour de courant.
Re: Problème étonnant avec ma mm2001
vendredi 9 avril 2010 19:22
Bonsoir,
Vous pouvez faire un test en diminuant la vitesse de coupe dans "jédicut" par exemnple multiplier le chiffre par 2. Si dans ce cas 9a fonctionne cet que le timer de la carte est passé sur 4000Hz. A essayer j'ai eu la cas et la fréquence du timer avait basculer sur 4000 au lieu de 2000Hz.

Alain
max
Re: Problème étonnant avec ma mm2001
samedi 10 avril 2010 12:08
salut a tous

merci pour ces conseils , je viens de commander un programmateur de pic
http://www.piccircuit.com/product.php?id_product=26

lorsque je le recevrais, je programmerais mon nouveau pic et on verras bien.
concernant le timer ,j'avais bien programmé la carte et le logiciel sur 4000hz ca ne viens donc pas de la .

merci a bientôt
Re: Problème étonnant avec ma mm2001
samedi 10 avril 2010 14:12
Bonjour,
Fais un test avec le timer à 2000Hz
Alain
max
Re: Problème étonnant avec ma mm2001
samedi 8 mai 2010 14:45
bonjour

depuis tout ce temps je n'avais pu retoucher à mon installation mais ce week end j'ai reprogrammé mon pic (celui sur lequel je doutais) et finalement tout fonctionne parfaitement mis à part le bip qui ne sonne pas au démarrage mais bon c'est pas dramatique.Maintenant on ne saura jamais pourquoi ce pic a mal fonctionner sur un moteur !!! enfin bref ca fonctionne c'est le plus important

je fait maintenant mes premiers pas avec jédicut et j'aurais surement des questions mais on verra plus tard

merci à tout le monde de m'avoir aider
max
Re: Problème étonnant avec ma mm2001
dimanche 23 mai 2010 23:50
bonsoirs a tous

pour ceux que ca intéresse ou ceux qui ont des problèmes similaires a ceux que j'ai eu, je signal que la version que j'utilise pour le programme du pic est la première version et non pas la v51. En effet, après mon problème j'ai acheté un nouveau pic et en même temps j'ai essayer de reprogrammer l'ancien. Sans faire exprès je me suis trompé et j'ai programmé l'ancienne version du programme sur l'ancien pic et ma carte a fonctionnr sans problèmes.
Lorsque je me suis rendu compte de mon erreur,j'ai programmé la nouvelle version dans mon nouveau pic,t je l'ai mis sur ma carte, et la exactement le même problème qu'avant, un des moteur ne fonctionne pas.
Depuis maintenant 2 semaines ,je tourne donc avec l'ancienne version sans aucun soucis, le seul inconvénient,c'est que je n'ai pas les petits bip au début pour connaitre le mode de pas et la fréquence du timer.

voila toute l'histoire a+ et bonnes découpes
Désolé, seuls les utilisateurs connectés peuvent envoyer des messages dans ce forum.

Cliquer ici pour se connecter



Et vous, vous venez d'où ?

Aeropassion

Paris en photo | Design by Le Flaketou, création de site internet

Phorum