Page d'accueil de Aeropassion
Partenaires du site :
Envoyé par Jerome 
Rotation irrégulière
samedi 14 octobre 2006 14:20
Bonjour,
J'utilise une machine semblable à celle du mra n°790,mais en utilisant jedicut, la rotation de mes moteurs pas à pas est très irrégulière, j'ai l'impression qu'ils "manquent des pas" ce qui n'est pas le cas avec gmfc. voici ma config:

-carte hobbycnc, moteurs medelor 200pas/tour 6 fils (http://www.medelor.com/moteurs/405X1X2X3.pdf) avec tige filetée de 1mm/tour.
-logiciel jedicut 0.00494mm/pas, MaxCom_XP.dll, configuration port parallèle comme décrite dans l'aide, vitesse découpe 17 et 6 et synchroniser avec le timer externe.

merci
Re: Rotation irrégulière
dimanche 15 octobre 2006 22:50
Bonjour,

Avec la carte hobbyCNC il faut utiliser les dll de la MM2001.

Jerome
Re: Rotation irrégulière
jeudi 19 octobre 2006 19:05
MaxCom_XP.dll est bien la dll adaptée à la carte mm2001?
Re: Rotation irrégulière
jeudi 19 octobre 2006 22:25
Bonjour,

Non, il faut utiliser CncNet_XP.dll

Jerome
Re: Rotation irrégulière
vendredi 20 octobre 2006 14:17
je ne comprend pas, j'utilise la dll CncNet_XP.dll et la rotation est encore irrégulière, les moteurs "loupent" encore quelques pas.
Re: Rotation irrégulière
vendredi 20 octobre 2006 14:43
Bonjour,

Si les moteurs loupent des pas, il faut regarder soit du côté des vitesses qui seraient trop élevé, soit du côté de l'electronique.

Poste le contenu de ton fichier Jedicut.ini pour que je puisse y jeter un oeil.

Jerome
Re: Rotation irrégulière
vendredi 20 octobre 2006 17:27
voici mon fichier .ini :

[General]
;
; Cycle de découpe par Défaut
; CycleDecoupeAile = nombre de phase:type:valeur:lissage:vitesse:qualification:
; Exemple avec une horizontale et une verticale de 10 et 20 avec lissage vitesse découpe, déplacement compté

CycleDecoupeAile=13:1:10:false:1:0:1:false:4:2000:false:0:0:0:false:0:10:false:0:1:0:false:2:0:false:0:1:36:false:0:10:false:0:1:0:false:1:10:false:0:1:2:false:0:10:false:1:2:36:false:1:10:false:1:2:36:false:0:10:false:0:1:0:false:3:0:false:0:1:36:false:0:10:false:0:1:0:false:1:10:false:0:1:2:false:0:10:false:1:2:0:false:

CycleDecoupeFuselage=12:1:50:false:1:0:1:4:2000:false:0:0:0:0:10:false:0:1:0:6:0:false:0:1:0:0:10:false:0:1:0:1:60:false:0:1:2:0:10:false:1:2:0:1:10:false:1:2:0:0:10:false:0:1:0:7:0:false:0:1:0:0:10:false:0:1:0:1:60:false:0:1:2:

; DllCommunication = Dll choisie par l'utilisateur
DllCommunication =CncNet_XP.dll

; Etat du Panel de Déplacement (1-non, 0-oui)
PDeplacement =1

; Langue de l'interface (= au nom du fichier xml sans son extension)
Langue=Français

; Configuration des dernières opérations utilisateur sur le panneau de contrôle
UtilisateurCheckDependance=0
UtilisateurCheckGuillotine=0
UtilisateurCheckLissage=0
UtilisateurCheckChauffe=0
UtilisateurCheckMateriau=0
UtilisateurNumMateriau=0
UtilisateurPourcentageChauffe=50

; FirstLoad=1 si c'est le premier lancement de Jedicut
FirstLoad=0

; Numéro de la version courante de Jedicut
JedicutVersion=2.1.4 build 0

;[MoteurXX]
;coeffPas = Nombre de mm effectués par pas du moteur
;inverserSens
; 0 : Sens Normal
; 1 : Sens Inverser
;vitesseDecoupe
;vitesseRapide
;bitHorloge = Bit d'Horloge
;bitSens = Bit de Sens

[MoteurX1]
coeffPas=0,005
vitesseDecoupe=17
vitesseRapide=6
bitHorloge=3
bitSens=2
inverserSens=1

[MoteurX2]
coeffPas=0,005
vitesseDecoupe=17
vitesseRapide=6
bitHorloge=7
bitSens=6
inverserSens=1

[MoteurY1]
coeffPas=0,005
vitesseDecoupe=17
vitesseRapide=6
bitHorloge=1
bitSens=0
inverserSens=1

[MoteurY2]
coeffPas=0,005
vitesseDecoupe=17
vitesseRapide=6
bitHorloge=5
bitSens=4
inverserSens=1

[Chauffe]

; Activer / Désactiver le contrôle de la chauffe (0-non, 1-oui)
ActiverChauffe =1

; Lire le mode de gestion de la chauffe sur le port // (0-non, 1-oui)
LireModeChauffe =1

; Liste des materiaux
; ListeMateriaux = nb materiau de la liste:materiau1:valeurChauffe1:materiau2:valeurchauffe2
ListeMateriaux =1:1:30:

; Liste des bits nécesaires à la gestion de la chauffe
BitHorlogeExterne =16
BitModeChauffe =15
BitSortieChauffe =22
BitEntreeChauffe =-1
BitAlimentationMoteur =23

; Synchroniser / Ne pas synchroniser les moteurs avec le timer externe
SynchroniserMoteurAvecTimerExterne=1
Re: Rotation irrégulière
vendredi 20 octobre 2006 17:33
Bonjour,

Je ne vois rien d'anormal dans ce fichier. Il faut vérifier le paramétrage du port parallèle dans le BIOS qui doit être en mode EPP je crois.

Jerome
Re: Rotation irrégulière
samedi 21 octobre 2006 19:36
voila
je suis allé dans le bios et j'ai trouvé plusieurs configuration:
AT, PS2, EPP, ECP et pour chacune on peut choisir "I/O channel": 378h, 278h et 3BCh et le DMA 1,2 ou 3 pour le mode ECP.

par défaut, c'était en mode PS2 mais en passant en EPP, cela n'a rien changé (jedicut me marque meme "time out si je suis en 278h) confused smiley

jespère que je suis assez clair yahoo smiley
Re: Rotation irrégulière
dimanche 22 octobre 2006 02:03
Salut, les channel c'est le numéro de port parallèle. Le port LPT1 est le 378h, le LPT2 278h, le LPT3 3BCh. Mais maintenant il n'y a souvent plus que le LPT1.

Au fait, quel est ton système d'exploitation?

Renaud
Re: Rotation irrégulière
dimanche 22 octobre 2006 11:05
Niloop,

Essaie EPP puis ECP (je ne sais plus ce qui faut mettre, je penche plus pour EPP). Pouj rle I/O channel, reste en 378h sinon tu auras toujours le même message de Jedicut qui dans ton cas indique simplement qu'il ne trouve pas le signal du timer externe.

Jerome
Re: Rotation irrégulière
dimanche 22 octobre 2006 11:32
je marche avec windows xp, je vais essayer différents modes
Re: Rotation irrégulière
lundi 23 octobre 2006 18:12
voila j'ai testé les modes EPP et ECP mais aucun n'a résolu mon problème.
j'ai l'impression que la régularité des pas dépend de l'utilisation du pc:
quand je fait un test sur une distance et que je lance une application ou meme bouge la souris sur un lien, le moteur ralenti.

c'est quand meme bizarre car presque la totalité du tour est effectué régulièrement, seulement quelques pas sont "manqués" et cela entrainent des vibration.
Re: Rotation irrégulière
lundi 23 octobre 2006 20:12
Bonjour,

Quel est le processeur du PC ? Et en ne touchant plus au PC après avoir lancé une découpe, ça donne quoi ?

Jerome
Re: Rotation irrégulière
lundi 23 octobre 2006 21:34
mon processeur est un pentium 4 à 2.5Ghz en ne touchant plus au pc et en fermant toutes les applications
il y a toujours des pas qui sautent. sa fait un peut comme le train sur un rail quoi.
je vais tester sur un autre ordinateur (portable) et je vous tiens au courant.
Re: Rotation irrégulière
jeudi 26 octobre 2006 16:33
Bonjour,
j'ai testé ma machine avec un portable mais ça n'a rien changé meme en me mettant en mode EPP.

ma carte est celle faite pour la découpe de chez hobbycnc et il y a des petits cavaliers permettant de passer du mode demi-pas à celui du pas complet, faut-il etre en demi-pas ou en pas complet?

merci
Re: Rotation irrégulière
jeudi 26 octobre 2006 17:19
Bonjour,

Commence par tester les pas complet. Et augmente le chiffre des vitesses (pour la diminuer et donc avoir un couple moteur plus élevé ).

Jerome



Modifié 1 fois. Dernière modification le 26/10/2006 17:21 par Jerome.
Re: Rotation irrégulière
vendredi 27 octobre 2006 09:39
Hello,

Controle aussi ta tension d'alimentation (moteur et carte). Si tout est régulier ou si il y a du bruit (avec un osillo si tu peux)... Peut-etre que celle des moteur est mal dimensioné et que quand tu tire du courant dessus (quand le moteur tourne) il y a une trop grande chute de tension...

En d'autre terme, regade si il y a bien 5V sur ta carte et 12V (je pense que tu a des SI55) sur tes moteur et qu'elle puisse fournir 2ampère.

A+
XAvier
Re: Rotation irrégulière
samedi 28 octobre 2006 16:37
bonjour,
j'ai testé les modes demi-pas et pas entier et les moteurs sont réguliers en mode demi-pas mais pas en pas complet.
du coté de l'alimentation , c'est une alim de pc et les moteurs sont alimentés à 70% de leur intensité nominale conformément à la notice de ma carte électronique.
Re: Rotation irrégulière
samedi 28 octobre 2006 17:14
Hello,

>> c'est une alim de pc et les moteurs sont alimentés à 70% de leur intensité nominale

Ok pour l'alime, mais le coup des 70%, ca m'étonne bcp, je pense que tu as pas besoin de cherché plus loin pourquoi tu perds des pas...
C'est qu'il leur manque de la tension...

Pour les moteurs pas à pas, tu peux meme les alimenter plus que leur tension nominal mais il faut limiter le courant et dans ce cas la je peux te dire que ca marche encore mieux (plus de couple, etc)

A+
Xavier
Re: Rotation irrégulière
samedi 28 octobre 2006 18:10
Là en fait, mes moteurs sont faits pour fonctionner à 1.1A en 4.1V et la carte leur envoie 0.79A
je suis donc à environ 80% de l'intensité nominale.
Dans la notice, on doit régler séparément 1 potentiomètre pour chaque moteur permettant de régler l'intensité mais je ne connais absolument pas la tension qu'il délivre.

Je suis un peu perplexe pour l'idée que l'on peut augmenter la tension mais limiter l'intensité.
l'intensité n'est pas le résultat d'une tension appliquée à une certaine résistance?

Je teste mes moteurs avec l'intensité nominale et je vous donne mes résultats.

En tout cas je vous remercie beaucoup pour l'aide que vous m'avez apportés !
niloop
Re: Rotation irrégulière
samedi 28 octobre 2006 18:54
voila j'ai fait les test, en effet les moteurs ne loupent plus de pas en mode pas entier.Mais pour une vitesse de découpe, le bruit est assourdissant, je vais donc rester en mode demi-pas car je n'ai pas besoin de beaucoup de puissance.
merci
Re: Rotation irrégulière
samedi 28 octobre 2006 20:38
Hello,

Je suis content que ca marche mieux...

>>Je suis un peu perplexe pour l'idée que l'on peut augmenter la tension mais limiter l'intensité.

Il suffit d'utiliser un "hachage" PWM... Je ne sais pas si ta carte gère cela...

Sinon il faudra attendre quelques temps car une "surprise" est en préparation smiling smiley... (mais chute, c'est un secret entre Jérôm et moi)

A+
Xavier
Re: Rotation irrégulière
lundi 30 octobre 2006 09:43
Que de mystère... ça m'intéresse tout ça!

Renaud.
Re: Rotation irrégulière
lundi 6 novembre 2006 10:15
Bonjour Niloop,

As tu un mode SPP pour le port parallèle dans ton BIOS ?

Jerome
Tof
Re: Rotation irrégulière
samedi 18 novembre 2006 17:00
salut salut !!!

Voilà, je viens de télécharger Jedicut 2.1.5 et j' utilise le matos suivant:

-pour ce qui est de la carte et des moteurs, voir ici :

http://www.selectronic.fr/article.asp?article_ref_entier=70.6157-2
http://www.selectronic.fr/article.asp?article_ref_entier=70.0393-1

-pour ce qui est du PC: ACER Aspire 1705 SMI (3,06 GHz, 2048 RAM, j' ai mis mon bios par défaut, soit pour le port // : ECP, LPT1 (378), IRQ7, DMA1

-pour ce qui est de l' alimentation : un peu comme tout le monde je pense !!!, c' est une alim ATX de PC => donc ça déboite en puissance, mais en regardant la notice de la carte, il est possible d' alimenter les moteurs en 13,8 V en mettant une résistance de 15 Ohms/5W non bobinée en série avec le bobinage du moteur ... mais là j' utilise le 5 V de l' alim.

Bref, j' ai réussi à faire tourner un moteur (car je possède les 3 autres mais faut que je cable le reste des composants sur la carte ... pfffffffffffff !!!!) , je ne sais pas comment ...car en + ça met une temps fou pour charger et démarrer les cycles de découpe, et je ne sais pas du tout d' où vient le problèmes malgrés les multiples changements de paramètres effectués dans Jedicut ...

Ah oui aussi , je n' arrive pas à faire fonctionner le mode manuel ... je suis un peu chat noir je crois ...

Tout l' ensemble fonctionne à merveille avec Comio Visual Motor ...

Merci Jérôme si tu as une solution à mes petits "bug"

Enfin, si il y aurais un fichier "setup" pour l' installation du soft, ce ne serait pas mieux ? car là en cemoment ce rien d' aure qu' une image de fichiers ...

Merci @+ !!! ;-)

Tof.
Re: Rotation irrégulière
dimanche 19 novembre 2006 11:14
Bonjour,

J'ai pensé à faire un setup, mais ça n'a pas grand intérêt puisqu'il suffit de dézipper l'archive téléchargeable sur le site et de lancer Jedicut.exe. C'est pour cette raison que je ne comprends pas le terme "image de fichiers". As tu dézippé le contenu de l'archive ?

Je constate que tu as acheté la carte Visual CNC. Cette carte fonctionne bien avec Jedicut. Pourrais tu poster le contenu de ton fichier Jedicut.ini ?

Jerome
Tof
Re: Rotation irrégulière
dimanche 19 novembre 2006 14:04
bonjour Jérôme,
oui j' ai bien dézippé le contenu ! alors voici le fichier "jedicut.ini":

[General]
;
; Cycle de découpe par Défaut
; CycleDecoupeAile = nombre de phase:type:valeur:lissage:vitesse:qualification:
; Exemple avec une horizontale et une verticale de 10 et 20 avec lissage vitesse découpe, déplacement compté

CycleDecoupeAile=13:1:10:false:1:0:1:4:2000:false:0:0:0:0:10:false:0:1:0:2:0:false:0:1:36:0:10:false:0:1:0:1:10:false:0:1:2:0:10:false:1:2:36:1:10:false:1:2:36:0:10:false:0:1:0:3:0:false:0:1:36:0:10:false:0:1:0:1:10:false:0:1:2:0:10:false:1:2:0:

CycleDecoupeFuselage=12:1:50:false:1:0:1:4:2000:false:0:0:0:0:10:false:0:1:0:6:0:false:0:1:0:0:10:false:0:1:0:1:60:false:0:1:2:0:10:false:1:2:0:1:10:false:1:2:0:0:10:false:0:1:0:7:0:false:0:1:0:0:10:false:0:1:0:1:60:false:0:1:2:

; DllCommunication = Dll choisie par l'utilisateur
DllCommunication =VisualCNC_XP.dll

; Etat du Panel de Déplacement (1-non, 0-oui)
PDeplacement =1

; Langue de l'interface (= au nom du fichier xml sans son extension)
Langue=Français

; Configuration des dernières opérations utilisateur sur le panneau de contrôle
UtilisateurCheckDependance=0
UtilisateurCheckGuillotine=0
UtilisateurCheckLissage=0
UtilisateurCheckChauffe=0
UtilisateurCheckMateriau=0
UtilisateurNumMateriau=0
UtilisateurPourcentageChauffe=50

; FirstLoad=1 si c'est le premier lancement de Jedicut
FirstLoad=0

; Numéro de la version courante de Jedicut
JedicutVersion=2.1.5 build 0

;[MoteurXX]
;coeffPas = Nombre de mm effectués par pas du moteur
;inverserSens
; 0 : Sens Normal
; 1 : Sens Inverser
;vitesseDecoupe
;vitesseRapide
;bitHorloge = Bit d'Horloge
;bitSens = Bit de Sens

[MoteurX1]
coeffPas=0.0025
vitesseDecoupe=100
vitesseRapide=20
bitHorloge=2
bitSens=3
inverserSens=0

[MoteurX2]
coeffPas=0.0025
vitesseDecoupe=100
vitesseRapide=20
bitHorloge=6
bitSens=7
inverserSens=1

[MoteurY1]
coeffPas=0.0025
vitesseDecoupe=100
vitesseRapide=90
bitHorloge=0
bitSens=1
inverserSens=1

[MoteurY2]
coeffPas=0.0025
vitesseDecoupe=100
vitesseRapide=90
bitHorloge=4
bitSens=5
inverserSens=0

[Chauffe]

; Activer / Désactiver le contrôle de la chauffe (0-non, 1-oui)
ActiverChauffe =0

; Lire le mode de gestion de la chauffe sur le port // (0-non, 1-oui)
LireModeChauffe =1

; Liste des materiaux
; ListeMateriaux = nb materiau de la liste:materiau1:valeurChauffe1:materiau2:valeurchauffe2
ListeMateriaux =1:1:30:

; Liste des bits nécesaires à la gestion de la chauffe
BitHorlogeExterne =16
BitModeChauffe =15
BitSortieChauffe =22
BitEntreeChauffe =-1
BitAlimentationMoteur =23

; Synchroniser / Ne pas synchroniser les moteurs avec le timer externe
SynchroniserMoteurAvecTimerExterne=0

donc voilà ! ah oui j' avais encore une question : la vitesse de découpe (dans les parametres), c 'est en mm/s ???

merci pour ton aide ...

Tof.
Re: Rotation irrégulière
dimanche 19 novembre 2006 15:30
Bonjour,

Tu as un pc puissant donc le problème de lenteur ne vient clairement pas du PC. Je crois que la carte Visual CNC possède un timer externe. Je te conseille donc d'activer l'option "Synchroniser les moeurs avec un timer externe" dans Jedicut. Si tu coches cette option, il faudra que tu revois tes vitesses qui se situeront surement vers 10. Cette valeur n'a rien à voir avec des mm/s car ça dépend de l'utilisation ou non d'un timer, et si il y a un timer, ça dépend de sa fréquence. Pour te donner une idée des configurations d'autres modélistes, tu peux regarder ce message : http://www.aeropassion.net/forums/read.php?5,365

Le pilotage manuel de la machine doit parfaitement fonctionné si une découpe peut être lancée. Je pense que tu n'as peut être pas choisi le bon moteur.

Un autre point étonnant chez toi : les vitesses que tu as réglé dans Jedicut sont incompatibles avec le fait de ne pas cocher l'option "Synchroniser..." dont je te parle au début du message.

Jerome
Tof
Re: Rotation irrégulière
dimanche 19 novembre 2006 15:54
me revoilà, penses tu que ça viendrait des moteurs ? 400 pas ça fait trop ? je les ai choisi pour la pécision. Quand je lance une découpe, le moteur fait un petit bruit (toc) puis s' arrete et j' arrive meme à le faire tourner à la main, donc il ne gere pas de couple. C' est comme si il voulait démarrer puis s' arrete tant dis que la barre de défilement continue "découpe en cours" ...

Mais je me réfère souvent avec les autres logiciels (Visual motor, Gmfc) : ça fonctionne !!! le moteur tourne bien , ralenti, et s' arrete au nombre de pas déterminé au préalable (sous Visual Motor).

Je vais essayer avec d' autres moteurs bipolaires ...

encore merci !!!
Désolé, seuls les utilisateurs connectés peuvent envoyer des messages dans ce forum.

Cliquer ici pour se connecter



Et vous, vous venez d'où ?

Aeropassion

Paris en photo | Design by Le Flaketou, création de site internet

Phorum