Page d'accueil de Aeropassion
Partenaires du site :
Envoyé par Jerome 
linux
vendredi 24 octobre 2008 14:21
Bonjour,

depuis 1 an j'utilise la distribution ubuntu de linux et depuis cette été je n'ai plus de pc avec windows.

Je viens de réaliser l'interface USB de xavtronic (que je remercie pour sa brillante conception et sa précieuse aide).

Sous linux pour utiliser un programme concu pour windows je ne connais que 2 méthodes :
-émuler un windows avec Wine, mais celui-ci (selon plusieurs forum) ne gère pas l'usb.
-émuler un bios pour installer windows.

Dans le premier cas Jedicut me dit "pas de machine" , ce qui confirmerais que Wine ne gère pas l'usb.

Dans le second cas, j'émule un bios avec Virtualbox dans lequel j'installe mon vieux windows 2000.
Là j'arrive à faire marcher Jedicut et j'obtiens les bons déplacement de ma machine.

Maintenant le seul problème, et là je sèche, c'est qu'au bout d'un moment en pleine découpe Jedicut plante et quand je le ferme une fenêtre apparaît
"L'instruction à "0x.........." emploie l'adresse mémoire "0x.........." . La mémoire ne peut pas être "read"."
Puis une autre "Runtime error 216 at 03F314E"

Si quelqu'un connais le problème et a la solution je suis preneur

je vais faire d'autres tests, je vous tien au courant

Merci
Alex
Re: linux
samedi 25 octobre 2008 12:03
Hello,

Pas de quoi pour l'aide, c'est tout a fait normal...smileys with beer

C'est peut-etre du à un manque de mémoire vive (RAM), pour mes émulation je parts sur une base de 256Mb(avec un win XP, à tester aussi à la place du 2000) et ca m'arrive d'augmenter jusqu'a 512Mb(j'ai que 1Go c'est pour ca que je m'arrête à la moitier (tongue sticking out smiley))

Donc en résumé, augmente la RAM alloué (meme si je pense pas que ce soit lié) et essaye avec un windows XP émul.

A+ et bonne chance, tiens nous au courant

Xavier

PS: Jérôme aura peut-être une autre piste.

PS2: Tu as bien le virtualbox "complet" par le OSE?



Modifié 1 fois. Dernière modification le 25/10/2008 12:04 par xavtronic.
Re: linux
samedi 25 octobre 2008 12:28
Bonjour,

N'ayant que peu d'expérience sous Linux, je ne vous serai pas d'une grande aide. Mais l'explication de Xavier me semble bien inspiré winking smiley

Si quelqu'un pouvait confirmer que tout fonctionne bien avec la dernière version de Jedicut sous Windows et avec l'adaptateur USB, ce serait déjà pas mal, nous serions "sur" (ou presque) que ça ne vient pas de Jedicut winking smiley

En tout cas je lis les comptes rendu de vos expériences avec plaisir winking smiley

Jerome
Re: linux
dimanche 26 octobre 2008 21:10
Bonsoir,

Jedicut avait très bien marché sur mon ancien PC sur le port parraléle sans usb et sous win2000 sans émulation

Je penche sérieusement sur un problème de mon émulation.

Xavier, je ne sais pas si j'ai VirtualBox OSE, j'ai le 2.04.
Pour la RAM, Je ne trouve pas la dénomination "ram", j'ai 2030Mo sur 3584Mo dans "taille de la mémoire de base"

A+
Alex
Re: linux
lundi 27 octobre 2008 10:27
Hello,

C'est lors de la configuration de la machine virtuelle que tu défini la taille de RAM physique allouée.

Mais comme tu dis cala peut venir de l'émulation, donc essaye avec une version émulé de XP.

A+
Xavier
Re: linux
lundi 27 octobre 2008 18:32
Bonsoir,

Après quelques test j'ai remarqué que j'ai ce message si l'adaptateur usb n'est pas branché à la mm2001.

j'arrive à faire un cycle de découpe complet sans erreur si je met la vitesse rapide à la même vitesse que le lente.

A+
Alex
Re: linux
lundi 27 octobre 2008 21:21
Hello,

Eut pas tout compris concernant les vitesses...

En faite c'est normal si la MM2001 n'est pas derrière l'adaptateur USB-CNC, ca ne fonctionnera pas car j'utilise le timer de la MM2001 (sinon il faut prendre l'autre version du firmeware pour des carte sans timerwinking smiley)

A+
Xavier
Re: linux
lundi 27 octobre 2008 22:29
bonsoir,

initialement ma vitesse rapide est de 10 et ma vitesse lente est de 20.
J'ai réussi à faire un cycle de découpe complet en réglant ma vitesse rapide à 20

A+
Alex
Re: linux
mardi 28 octobre 2008 23:14
Bonsoir,

j'ai trouvé ça mais http://pascal.developpez.com/faq/?page=Pg_TPFatalErrors#TPRuntimeError216

mais ça ne m'aide pas trop
j'ai tous essayé dans les configuration et je ne vois pas ce qui me fait planter jedicut

A+
Alex
Re: linux
mercredi 29 octobre 2008 19:20
Ça y est j'ai obtenue un bon résultat, j'ai supprimé la pause dans mon programme et là Jedicut n'a pas planté.
Seulement j'ai toujours les message d'erreur quand je ferme Jedicut
Re: linux
mercredi 29 octobre 2008 22:03
Voilà une bonne nouvelle ! Félicitation !

Reste à comprendre pourquoi maintenant, et ça c'est une autre paire de manche...

Jerome
Re: linux
jeudi 30 octobre 2008 19:46
Bonsoir,

Je pense avoir affiné la cause de mon problème, j'ai désactivé le contrôle de la chauffe et tout ce passe sans problème.

Quand le contrôle de la chauffe était activé j'avais remarqué que la diode de témoin de chauffe clignotait de magnanière irrégulière, ce qui m'a mis la puce à l'oreil.

J'ai dû faire une mauvaise soudure sur la patte 4 du pic ou sur la 16 de la broche 25 pin (Xavier pourrais-tu me confirmer?)

Merci
Alex
Re: linux
jeudi 30 octobre 2008 20:51
Hello,

Si les moteurs tourne bien et que ca détecte le mode manuel/auto et la bonne valeur de chauffe en cas de lecture, alors c'est les 2 soudures que tu cites qui peuvent avoir un problème.

Sinon peut-être que l'émulation ne tourne pas assez vite pour supporter les 10kHz du timer, c'est une autre possibilité à controler.

A+
Xavier
Re: linux
jeudi 30 octobre 2008 22:37
ce we je fait un test sur une machine non émulé, je test les soudures et je vous tien au courant

A+
Alex
Re: linux
samedi 15 novembre 2008 10:15
bonjour,

Après plusieurs essais j'arrive à faire tourner ma MM2001 et l'adaptateur usb sous linux.

j'utilise VirtualBox qui émule un PC virtuelle dans lequel j'ai installé windows 2000.

les différents problème que j'ai eu était sans doute dû à mes mauvaise soudure sur mon interface usb (voir photos)



Si quelqu'un veux plus d'information je répondrais volontier à toutes les questions

Merci à Xavier et Jérome qui mont bien aidé.

Alex
Re: linux
samedi 15 novembre 2008 11:02
Salut et félicitation !

Pourrais tu nous faire un petit guide de configuration et d'utilisation de virtual box ? si ça peut éviter à certain de chercher... winking smiley

Jerome
Re: linux
samedi 15 novembre 2008 14:10
Hello,

C'est une bonne nouvelle ca! Comme ceci on est deux à avoir réussit à faire tourner le tout en émulation!

Les mauvaises soudures sont souvent l'un des principaux problèmes du non fonctionnement d'un montage électronique (tongue sticking out smiley) .

C'est une bonne idée d'avoir fait la carte sur plaque perforée, au moins tu prouve que l'on peut faire plus simplement que ce que je propose winking smiley.

Bon week end.
Xavier
Re: linux
dimanche 16 novembre 2008 09:37
salut!

Pas de problème Jérome, je vais faire un petit doc sur la configuration de la machine virtuel.

J'ai utilisé une carte perforée car je ne peux pas utiliser de révélateur ni du perclo c'était plus simple pour moi.

Bon we
Alex
Désolé, seuls les utilisateurs connectés peuvent envoyer des messages dans ce forum.

Cliquer ici pour se connecter



Et vous, vous venez d'où ?

Aeropassion

Paris en photo | Design by Le Flaketou, création de site internet

Phorum