Page d'accueil de Aeropassion
Aeropassion's parteners :
Envoyé par SL 
SL
Erreur programme
lundi 18 octobre 2010 19:32:42
Bonjour

Problème avec Jedicut :

J'utilise une MM2001 donc le pilote CncNet_XP.dll
Jedicut a parfaitement fonctionné jusqu'à ce que je fasse une entrée de nouveau matériaux (avec test de chauffe qui a bien fonctionné).
Après avoir Appliquer, lors de la sortie (OK), j'ai eu un message genre :
" n'est pas un nombre en virgule flottante valide.

Le problème est que maintenant, au lancement et lors de toute opération conduisant à un déplacement chariots, au lieu de ce déplacement, j'ai un message "division par 0". Et ce même " n'est pas un nombre en virgule flottante valide quand je sors de la fenêtre Options..

J'ai désinstallé et réinstallé le programme, mais le message revient. Il semble qu'un paramètre (avec la config) soit enregistré quelque part et repris même après uninstall, réinstall.n'ai pas trouvé de Jedicut.ini ni dans la base de registre quelque chose à effacer pour annuler un mauvais paramètre.

Il y a toujours la solution de réinstaller Windows, mais si je pouvais éviter...

Merci de me donner un tuyau pour ça.

SL
Re: Erreur programme
lundi 18 octobre 2010 19:58:10
Bonjour,

Il suffit d'une erreur de saisie dans une valeur que tu as modifié. As tu ajouté un matériau dans la liste ? Si oui, supprime le. Si ça ne marche pas, désinstalle Jedicut, et fait une recherche de Jedicut.ini sur ton disque système, ou dans le répertoire d'installation de Jedicut (tout dépend de comment tu l'as installé). Supprime ce fichier et réinstalle Jedicut. Il faudra reconfigurer le tout, mais ça fonctionnera winking smiley

Jerome
SL
Re: Erreur programme
lundi 18 octobre 2010 23:58:58
Merci

J'avais ajouté un matériau dans la liste, j'avais ensuite essayé de réécrire toutes les données sans résultat.

Malheureusement, il n'y a pas de jedicut.ini sur ma machine.
La recherche me donne pas mal d' .INI, mais pas pour Jedicut.

Je trouve un JEDICUT.EXE-1C441987.pf dans Windows\prefectch

qui évolue quand je lance Jedicut mais qui est incompréhensible.

J'utilise la version 2.2.2 build 0

Une idée ?

SL
Re: Erreur programme
mardi 19 octobre 2010 19:40:43
Il y a obligatoirement un fichier Jedicut.ini.

Tu dois avoir des fichiers cachés sur ton Windows (Dans ton explorateur, menu Outils/options, et tu dois avoir une option pour afficher les dossier masqué). Le fichier doit se trouver dans le répertoire commun des applications.

Autre façon de faire, va dans Jedicut malgré le message d'erreur, et supprime tous les matériaux.

Jerome
SL
Re: Erreur programme
mardi 19 octobre 2010 23:15:56
Oui, pas de Jedicut.ini visible.

J'ai fait affiché tous les fichiers même cachés et les dossiers système.

Une recherche *.ini sur mon poste de travail me sort 452 fichiers .ini, mais pas de Jedicut.ini

Il doit pourtant bien exister puisque les paramètres sont conservés.

Mais comme je le disais, le seul qui évolue est JEDICUT.EXE-1C441987.pf mais même si je le supprime, la config est retrouvée.

Après avoir créé un matériau, je peux le supprimer, mais les messages d'erreur persistent.

c'est finalement la suppression de la table active (Defaut) qui a été la solution.

Petites suggestion d'un utilisateur :

- Ajouter en fin de découpe une verticale pour que la machine revienne à son point de départ (Je l'ajoute systématiquement dans le cycle de découpe pour faire plusieurs découpes à la suite).

- Laisser les moteurs bloqués entre les découpes car quand les chariots sont lourds, ils ont tendance à descendre tous seul et on perd les positions de références.

Merci

SL
SL
Re: Erreur programme
mercredi 20 octobre 2010 00:22:38
Ouf, j'ai fini par trouver un fichier jedicut_Defaut dans

C:\Documents and Settings\All Users\Application Data\Jedicut

Ça me chagrinai bien ce truc !

Curieusement, les fichiers cachés apparaissent bien dans l'explorateur (si on a coche la case ad-hoc), mais pas dans la liste des fichiers obtenus par Recherche. Encore une connerie Windows ?

Tout rentre dans l'ordre.

Encore merci.

SL

____________________________________________
Mes travaux sur l'aéromodélisme, c'est ici :
http://sylvain.lichtenberger.perso.sfr.fr/pages/intropag.html
Les ailes du mini racer sont découpées avec Jedicut.



Modifié 1 fois. Dernière modification le 20/10/10 00:24 par SL.
FX Roussel
Re: Erreur programme
jeudi 28 octobre 2010 16:41:25
Bonjour,

J'ai réalisé la carte mm2001 avec le logiciel v51.

La led moteur clignote, est-ce normal ?

Aux tests en manuel, les moteurs tournent de un demi à trois quarts de tour(en fonction de la vitesse) , arrêtent puis repartent et ainsi de suite

En d'autres termes, je n'arrive pas à obtenir un fonctionnement continu.

A l'oscilloscope, les signaux d'entrée du pic sont corrects mais à la sortie ,vers les transistors, les signaux sont séquentiels au même rythme que le fonctionnement des moteurs...

Ce qui est encore plus troublant, c'est que tout fonctionnait au début et que ces problèmes sont arrivés brutalement sans aucune intervention de quoi que ce soit.

Merci infiniment de bien vouloir m'aider

FX Roussel
368 rue de Lambres
59500 Douai
03 27 87 01 14

fxroussel688@orange.fr
SL
Re: Erreur programme
jeudi 28 octobre 2010 17:56:34
Absolument anormal que la LED moteur clignote. Ça explique le fonctionnement aléatoire des moteurs.
La LED est pilotée par la sortie 17 du PC.
Tests à faire :

- Regarder la broche 33 du PIC. Elle doit être stable, à 1 quand les moteurs tournent.
Si elle est "variable", voir en sortie du PC sur la LPT. Il peut y avoir un défaut dans le SW1.

- Forcer l'entée 33 du PIC à 1 et regarder si tout rentre dans l'ordre.

- Essayer avec un autre PC.

- S'assurer que c'est le bon driver qui est utilisé (MaxCom_XP.dll)

C'est quoi le logiciel V51 ? On en est à la version 2.2.2.

____________________________________________
Mes travaux sur l'aéromodélisme, c'est ici :
http://sylvain.lichtenberger.perso.sfr.fr/pages/intropag.html
Les ailes du mini racer sont découpées avec Jedicut.
Seuls les utilisateurs enregistrés peuvent poster des messages dans ce forum.

Cliquez ici pour vous connecter



Aeropassion

Paris en photo | Design by Le Flaketou, création de site internet

Phorum