Page d'accueil de Aeropassion
Aeropassion's parteners :
Envoyé par Luc 
Luc
module de chauffe mdlcnc
dimanche 19 février 2012 16:42:35
Bonjour
Je termine la construction de ma table de découpe avec une carte MDLCNC , le module de chauffe, les moteurs et les alimentations de chez Modellbau Letmathe . Voici mon problème: tout va bien lorsque le module de chauffe n'est pas alimenté en 5v (à partir de la carte moteur) et la case "synchroniser la rotation des moteurs avec un timer externe" et décocher. Par contre si je coche la case les moteurs ne tournent plus. Si la case n'est pas coché mais que le module de chauffe est alimenté en 5v les moteurs tournent mais le fil ne chauffe plus (seulement 2v aux extrémités). J'utilise la DLL MDLCNC_XP.DLL dont la description indique "no timer and no heating control". C'est peut-être la cause du problème, mais comment faire?
merci pour vos conseil
Luc
Re: module de chauffe mdlcnc
lundi 20 février 2012 18:00:23
Bonjour Luc,

Je te confirme qu'il y a au moins un problème au niveau du plugin de communication que tu as choisis. Quand tu parles du module de chauffe, c'est bien l'adaptateur avec un port parallèle d'un côté et un port parallèle de l'autre qui permet d'ajouter un timer externe et le contrôle de la chauffe ?

Si c'est bien ça, il faut que tu changes de plugin de communication et que tu prennes le plugin CncNet_XP.dll et de cocher "synchronisation des moteurs avec un timer externe". Tu pourras alors utiliser le contrôle de la chauffe et utiliser le timer pour cadencer la rotation des moteurs, comme avec une carte MM2001.

Jerome
Luc
Re: module de chauffe mdlcnc
lundi 20 février 2012 18:51:09
Bonjour Jerome
Merci pour la réponse, c'est bien l'adaptateur en question, je testerai ta solution jeudi ou vendredi, et te dirai ce qu'il en est
Luc
Luc
Re: module de chauffe mdlcnc
jeudi 23 février 2012 09:38:14
Bonjour

J'ai testé le plugin CncNet_XP.dll avec la carte MDLCNC en cochant la case "synchronisation des moteurs avec un timer externe" , les moteurs tournent mais la chauffe ne fonctionne pas. lors de l'essai de chauffe le pourcentage indiqué est de 1 %, par contre si je débranche l'alimentation en 5v de l'adaptateur de chauffe MDLCNC (le même que celui présenté dans l'actualité de jédicut) le fil chauffe. Faut'il changer les numéros des connexions entrée chauffe, sortie chauffe etc.
Merci pour ton aide
Luc
Re: module de chauffe mdlcnc
vendredi 24 février 2012 09:02:17
Le test de chauffe que tu lances sert à trouver les bons pourcentages de chauffe à deux vitesses de déplacement différentes. Donc si la carte envoie 1% au pc et que tu n'as pas de bouton + et - pour la régler manuellement, c'est normal que tu lises toujours la même valeur.

Mais quand tu laisses le 5V branché et que tu fais un déplacement manuel depuis Jedicut avec une chauffe à 50% ça chauffe ? et avec une valeur de chauffe à 100% ça chauffe plus intensément ?

Jerome
Luc
Re: module de chauffe mdlcnc
vendredi 24 février 2012 11:40:59
Cela ce complique, avec le plugin CncNet_XP.dll lorsque la case "synchronisation des moteurs avec un timer externe" est cochée et l'adaptateur de chauffe branché en 5V les moteurs ne tournent pas. La case décochée, en manuel les moteurs tournent mais par à coup, si je recoche la case, un test de chauffe fait tourner les moteurs par à coup, avec un déplacement de 5 mm au lieu de 10 demandé, sans rien changé sur un essai en manuel les moteurs ne tournent plus. J'ai répété la séquence plusieurs fois à l'identique! Pour la chauffe, je n'avais pas vu le petit potentiomètre sur la carte, lorsque je le tourne le fils chauffe plus fort. la carte est vendue avec 3 cavaliers, je suppose 2 pour régler la fréquence, et le 3ème (à coté du potentiomètre) je ne sais pas encore sa fonction.
Par contre le 5v débranché les moteurs tournent normalement. J'en arrive a douter de mon test d'hier, et je suis bien perdu. Jérome, as-tu testé l'adaptateur de chauffe après ton test de la carte moteur MDLCNC?
Merci de ton aide
Luc
Luc
Re: module de chauffe mdlcnc
vendredi 24 février 2012 12:35:30
Suite du message précédent. J'obtient toujours un fonctionnement étrange qui dépend des options précédentes, par exemple, sur un dernier essai ou les moteurs et la chauffe fonctionnent en mode test chauffe, j'inverse le sens des moteurs car j'étais arrivé au bout de la table, et plus rien ne fonctionne. En cochant et décochant les cases synchronisation et activation de la chauffe, cela fonctionne a nouveau! Par contre même lorsque cela fonctionne et qu'en réglant le potentiomètre de chauffe sur le module de chauffe j'obtient une belle coupe (en mode test de chauffe) jédicut dit toujours que la chauffe est à 1%, j'y comprend rien.
Re: module de chauffe mdlcnc
samedi 25 février 2012 09:26:06
Luc,

Quand tu branches le 5V il me semble que ça sert à alimenter le timer externe.

Quand tu décoches "synchroniser...", tu mets quoi comme vitesse ?
Et quand tu coches cette case, tu mets quoi comme vitesse ?

Je n'ai pas encore eu le temps de tester ce module car il faut que je rebranches ma carte de test, et que je trouve une alim 5V... Et que je trouve du temps winking smiley

Jerome
Luc
Re: module de chauffe mdlcnc
samedi 25 février 2012 10:07:21
Jérome

Le 5V sert en effet à alimenter le timer externe, le 5V est pris sur la carte moteur MDLCNC, (pas besoin d'alim 5V) la prise ressemble à un branchement de cavalier à coté du port parallèle, le positif vers l'extérieur de la carte coté port parallèle.
Quand je décoche "synchroniser "j'ai 0.0025mm par pas (1mm/400pas) et 2000000 en rapide et 1000000 en lent
Quand je coche cette case la vitesse est réglé par le curseur entre lent et rapide et j'ai essayé à plusieurs valeurs intermédiaires
J'ai reçu par mail de Letmathe le mode d'emploi du module, le cavalier à coté du rhéostat : débranché=chauffe manuelle, branché= chauffe pilotée ordi
Dans mon cas la chauffe manuelle fonctionne, avec la chauffe pilotée le fil reste froid
Sur le manuel il y a les numéros de pin pour les moteurs mais pas pour le timer et la chauffe.
J'ai vraiment l'impression que se sont les numéros de broches du câble parallèle qui ne sont pas bon pour la chauffe et le timer. Quel est le risque de les changer? éventuellement quel numéro tester? et dans quel ordre? Pourrais-tu demander à Frank de Letmathe?
Merci pour ton aide
Luc
Re: module de chauffe mdlcnc
dimanche 26 février 2012 18:42:39
Je n'ai pas reçu le petit cordon pour alimenter l'adaptateur.
Quand tu coches "synchroniser" tu mets quelles vitesses ? Avec l'adaptateur et pour avoir la chauffe il faut cocher cette case. Ensuite poireaute régler la chauffe tu dois te mettre en mode chauffe contrôler manuellement. Puis tu lances un test. En faisant varier la chauffe manuellement tu dois lire des valeurs différentes dans Jedicut.
Tu ne risques rien à changer le réglage des pins. j'ai placé des protections.

Jerome
Luc
Re: module de chauffe mdlcnc
jeudi 1 mars 2012 17:26:27
Bonjour Jérome

Quand je coche "synchroniser" j'ai mis à l'aide du curseur soit 2000000 la vitesse la plus lente, soit 1500000, soit 1000000 la vitesse la plus rapide, cela ne change rien car le problème n'a pas l'air d'être là. J'ai testé sans succès de nombreuses combinaisons de numéro de pins de timer externe, de moteur on/off et de chauffe. Dans tous les cas j'ai la même séquence: je branche la carte, case "synchro" pas coché, les moteurs tournent correctement - case "synchro" coché ils ne tournent plus - case synchro décoché les moteurs tournent par a-coups. Le % de chauffe indiqué reste bloqué sur 1%. Il faut couper l'alimentation de la carte puis la rebrancher pour que les moteurs tournent a nouveau correctement.
J'en conclu un problème de plug-in inadapté (CncNet_XP.dll) ou de mauvaise combinaison de codes pin. Lorsqu'il y a quelque temps je t'avais demander sur ce forum si la config avec jedicut, carte letmathe et module de chauffe était bonne, tu avais pris la précaution d'envoyer un mail à Franck, le boss de Letmathe, avant de m'assurer que c'était une config parfaite. Comme cela ne fonctionne pas, ce qui évidemment n'est pas de ta faute, pourrais-tu demander à letmathe ce qu'il faudrait faire pour que le module de chauffe fonctionne avec Jedicut, puisqu'il semble fonctionner avec d'autres logiciels.
Luc
Re: module de chauffe mdlcnc
jeudi 1 mars 2012 21:31:15
Si tu coches la synchro avec le timer, il faut mettre des vitesses comprises environ entre 10 et 30. Tu peux déjà essayer ça ? Avant de t'acharner sur la chauffe il faut réussir à faire tourner les moteurs avec la synchro timer cochée.
Ensuite pour la chauffe quand tu fais le test tu es en mode manuel ou pc ?

As tu essayé de contacter le vendeur ? l'adaptateur doit marcher avec tous les logiciels compatibles mm2001.

Je n'ai pas le temps de tester le miens donc je ne peux pas faire mieux que de te guider via ce forum.

Jerome
Luc
Re: module de chauffe mdlcnc
vendredi 2 mars 2012 09:13:17
J'en conclu qu'en attente d'un plug-in adapté le module de chauffe de letmathe MDLCNC G4M présenté sur le blog est incompatible avec jedicut, il faudrait peut-être avertir les membres du forum, parce qu'un fois le matériel acheté, faute de plug-in, il faut changer de logiciel.
Luc
Re: module de chauffe mdlcnc
vendredi 2 mars 2012 19:22:54
Mauvaise conclusion. Si la carte branchée au pc utilise le même protocole que la mm2001 alors les plugins pour Jedicut existent déjà.

Si tu veux mon aide bénévole, réponds à mes questions. Si tu ne les comprends pas on peut en discuter.

Jerome
Luc
Re: module de chauffe mdlcnc
vendredi 2 mars 2012 22:13:50
Les cartes branchées au PC sont celles que tu signales sur le blog : carte 4 moteurs MDLCNC et module de chauffe MDLCNC G4M, est-ce qu'elles utilisent le même protocole que la mm2001? je n'en sais rien, la carte fonctionne avec jedicut, le module de chauffe ne fonctionne pas avec jedicut. J'ai déjà répondu précisément à ta question sur la vitesse. Dans l'onglet option chauffe on ne rentre pas une vitesse mais on on la choisi en déplaçant un curseur entre les valeurs mini et max mis dans la configuration machine, dans mon cas les valeurs ne sont pas entre 10 et 30 mais entre 1000000 et 2000000! et le nombre de mm par pas est de 0.0025 (1mm par tour divisé par 400 pas). Si ces valeurs que je t'avais déjà annoncées posent problème, explique moi pourquoi cela ne fonctionne pas avec des valeurs plus petites.
D'autre part, actuellement je ne m'acharne pas sur la chauffe mais sur le fonctionnement avec la case "synchro..." coché, j'ai testé de nombreuses vitesses et de nombreux numéro de pins pour le timer externe et le moteur on/off, le résultat est toujours le même: voir message du 1er mars 17h26
Je sais très bien que ton aide est bénévole et je ne te reproche pas que cela ne fonctionne pas, je dis seulement que soit il faut trouver une solution, soit il faut signaler que cela ne fonctionne pas (peut-être momentanément).
Luc
Re: module de chauffe mdlcnc
samedi 3 mars 2012 09:16:56
La sélection de la vitesse des moteurs dans l'onglet de test de la chauffe ne sert qu'à configurer la chauffe automatique.

Où on règle la vitesse des moteurs dans Jedicut en fonction de sa machine : dans l'onglet de réglage moteur, là où tu as réglé le nombre de mm par pas.

Donc tu vas dans les Options de Jedicut, tu coches la case "synchroniser..." Dans l'onglet communication, puis tu vas dans l'onglet machine et tu changes les vitesses en mettant une valeur entre 10 et 30 dans un premier temps. Ensuite tu pourras optimiser les réglage des vitesses mais en mettant une valeur entre 10 et 30 les moteurs devraient déjà tourner. Quand c'est fait tu cliques sur OK.

Ensuite dans le panneau latéral de Jedicut permettant de piloter manuellement la machine, tu lances un déplacement sur le moteur sur lequel tu a changer la vitesse.

Si c'est trop lent, tu baisses la valeur de la vitesse du moteur, si c'est trop rapide ou si ça "broute", tu augmentes la valeur de la vitesse. Contrairement aux réglages quand on n'a pas de timer, cette fois les chiffres doivent être petits (regarde sur le forum la discussion ou des modélistes indiques leurs réglages).

J'ai envoyé à mail à Franck pour lui demander la configuration des pin de son adaptateur.

Jerome
Luc
Re: module de chauffe mdlcnc
samedi 3 mars 2012 17:00:49
Et ben voila ce qu'il fallait dire, les réglages de vitesses sont très différents selon que la case "synchro..." est coché ou non. Merci de l'info, avec ces réglages les moteurs fonctionnent avec la "synchro... " active. Un problème de réglé, par contre la chauffe ne fonctionne toujours pas, j'ai testé avec les cases "lire le mode chauffe sur le port parallèle" et "active la chauffe dynamique "cochées ou non. Lors des tests de chauffe, la chauffe mesurée reste à 1% et le fil reste froid quelque soit la position du rhéostat, par contre avec le cavalier enlevé sur le module G4M (donc en mode carte manuel) le fil chauffe en fonction de la position du rhéostat mais la mesure dans jédicut est toujours à 1% quelque soit la position du rhéostat. J'ai fait des tests de numéro de pin sans succès, j'espère que Franck pourra nous indiquer la bonne configuration.
Point de vue vitesse, avec 30 et 10 la vitesse de ma machine correspond à ce qui est estimé dans la page des paramètres, en vitesse rapide j'ai fait un test avec 2 au lieu de 10 et sur 200 mm la distance parcourue est bien de 200 mm (mesurée avec une règle donc pas très précis), le problème de la vitesse est-il bien le risque de perte de pas, et donc de précision, ou il y a t-il des risques en plus?
Luc
Re: module de chauffe mdlcnc
samedi 3 mars 2012 20:40:11
C'est ce que j'avais dit dans mon message du 1 mars 21h31 winking smiley

Le seul risque est celui de perdre des pas. Mais quand tu en perds ça s'entend, les moteurs font un drôle de bruit...

Pour faire le test de chauffe dans Jedicut, il faut être en mode chauffe "manuel" au niveau de ta carte et jouer avec ton rhéostat. Et à chaque test, si tu fais varier la chauffe, tu devrais lire 1% dans Jedicut, puis 100% si tu vas à l'autre extrémité du réhostat. Peut être que Jedicut n'arrive pas à lire le signal de chauffe. As tu essayé plusieurs valeur de fréquence de timer ? Je crois que ça se règle au niveau de ta carte. Je ne sais pas ce qui est idéal (voir la fréquence pour la MM2001), mais peut être que Jedicut n'arrive pas à lire un signal avec une fréquence trop élevée... J'attends toujours la réponse de Franck.

Actuellement tu as quelle fréquence de sélectionné sur le module G4M ?

Jerome
Luc
Re: module de chauffe mdlcnc
samedi 3 mars 2012 21:16:27
La précision supplémentaire sur la différence de réglage avec ou sans synchro était utile à ma compréhension, mais pas de polémique inutile.
La fréquence se règle sur la carte à l'aide de 2 cavaliers, si j'ai bien compris, avec les 2 cavaliers positionnés c'est 4 KHZ, sans les deux c'est 20KHZ et les fréquences intermédiaires sont avec le cavalier 1 ou le 2 seul, à moins que ce soit l'inverse, mais j'ai essayé toutes les positions (en débranchant la carte à chaque fois car la fréquence est lue à la mise sous tension) et rien ne change. En tournant le rhéostat de mini à maxi le fil passe de froid à très chaud mais la chauffe mesurée est toujours de 1%. Je pense également à un problème de communication entre la carte et jédicut, mais comment le résoudre?
Luc
Re: module de chauffe mdlcnc
dimanche 4 mars 2012 04:17:09
Hello,

at the MM2001 the communication is at pin-11(par-port).
On this pin comes the pwm-puls from manuel heating.
On pin-12 is the information for heating manuel or PC.
Which pin is it on your cart?

Can you send a datasheed from your cart?

Manfred
Re: module de chauffe mdlcnc
dimanche 4 mars 2012 10:09:43
Me voilà avec quelques explications après discussion avec Franck, et ça reste à confirmé.

Apparemment le module G4M n'envoie pas de signal au PC pour lui indiquer si le fonctionnement de la chauffe est automatic ou manuel, contrairement à ce que fait la MM2001 via le pin 12. ça expliquerai peut être pourquoi Jedicut n'arrive pas à lire la valeur de chauffe. Je pense que Jedicut lit l'état de ce signal avant de lire la chauffe (ça je dois vérifier).

Par contre quand tu sélectionnes le mode "PC" sur ton module, et que tu demandes un déplacement manuel avec réglage manuel de la chauffe dans Jedicut (volet de droite dans Jedicut), tu dois voir la chauffe varier. Franck m'apprends que si on lance une découpe avec une chauffe réglée manuellement dans Jedicut, ça ne chauffe pas. Je pense que dans certain cas Jedicut fait un contrôle et ne calcule rien ni n'envoie aucun signal de chauffe si le signal du pin 12 ne dit pas "réglage PC".

Peux tu préparer une découpe, activer le contrôle de la chauffe dans les options de Jedicut, cliquer sur "Découper" dans le menu, et me dire ce que tu vois en face de "Mode de chauffe de la machine :" ? Tu dois lire "manuel" ou "PC", sur fond blanc, vert ou rouge.

Si tout ça se confirme il faudra que je fasse un plugin special :/

Jerome
Luc
Re: module de chauffe mdlcnc
dimanche 4 mars 2012 11:10:29
Bonjour
voici la configuration dans jedicut
plug-in CncNet_XP.dll

Timer externe 10 Sortie chauffe 16
moteur on/off 17 Entrée chauffe 11
Etat chauffe 12
fréquence timer 4000 Hz
La carte est une carte MDLCNC 4 moteurs avec carte de chauffe externe MDLCNC GMFC Interface G4M
Le timer externe est reconnu mais la communication chauffe-Jédicut ne se fait pas.
Luc
Luc
Re: module de chauffe mdlcnc
dimanche 4 mars 2012 11:17:28
J'ai répondu a Manfred avant de voir ta réponse en page 2, je test cela cet après midi
Luc
Luc
Re: module de chauffe mdlcnc
dimanche 4 mars 2012 15:20:08
Quand je sélectionne le mode pc sur le module et en déplacement manuel et réglage manuel de la chauffe dans jédicut, la chauffe fonctionne et varie selon le pourcentage demandé.
J'ai lancé une découpe en activant le contrôle de chauffe dans Jédicut, le message au moment de la confirmation est PC sur fond rouge, les moteurs tournent correctement mais même avec le rhéostat au maxi sur le module, le fil est à peine chaud, pas assez pour laisser une empreinte dans le polystyrène.

Luc
Re: module de chauffe mdlcnc
dimanche 4 mars 2012 15:49:55
Je vais contrôler mais "PC sur fond rouge" signifie que le mode chauffe est PC au niveau de Jedicut, mais que la carte est en mode "manuel", ce qui confirme ce que m'a dit Franck et ce que j'ai vu sur le schéma de l'adaptateur : le pin 12 est connecté à la masse, il est donc toujours dans le même état... Je suis étonné que GMFC ne fasse pas de contrôle sur ce signal de la MM2001.

Je te préparerai un plugin Luc dès que j'aurai un moment. En attendant, la chauffe via Jedicut ne fonctionnera pas, sauf via des déplacements manuels, ou si tu règles la chauffe manuellement sur le module G4M.

Jerome



Modifié 1 fois. Dernière modification le 10/03/12 11:14 par Jerome.
Luc
Re: module de chauffe mdlcnc
dimanche 4 mars 2012 16:59:42
OK je vais préparer mes fichiers de découpe en attendant et merci d'avance pour le plug-in MDLCNC G4M
Luc
Re: module de chauffe mdlcnc
dimanche 4 mars 2012 23:16:18
Hello Luc,

you can also good cut without heating control from Jedicut.
(i make it always for critcally or testing cut's)


Manfred
Re: module de chauffe mdlcnc
samedi 10 mars 2012 11:23:26
Bonjour Luc,

Après avoir passé la matinée sur le problème que tu as indiqué, j'ai besoin que tu fasses quelques tests car un point m'échappe.

Ton adaptateur ne remonte pas l'information au PC disant si tu es en mode "contrôle externe" ou "controle PC" de la chauffe. D'ailleurs j'ai changé ce libellé dans Jedicut pour que ce soit plus clair dans la fenêtre de confirmation de découpe. Maintenant elle affichera si la chauffe est en mode "PC" ou "Externe".

J'ai fait des tests avec le plugin FileTrace qui est un plugin me permettant de tester Jedicut sans avoir de machine et voici quelques questions.

- Quand tu mets l'adaptateur en mode "contrôle chauffe par le PC", si tu crées un fichier de découpe et si tu cliques sur "Découper" dans le menu, qu'est ce que t'affiche Jedicut en face de "Mode de chauffe de la machine" ?

- Même test quand tu mets l'adaptateur en mode "contrôle chauffe manuel" ?

- Après ces tests, dans les options de Jedicut, dans l'onglet "Chauffe", as tu coché "Lire le mode de chauffe..." ?

- Autre test, si décoche la case si dessus, et que tu ouvres le panneau latéral de Jedicut permettant de demander des déplacements manuels, est ce que tu peux cliquer sur la case "Activer Chauffe" ?

- Les réglages des pins que tu cites un peu plus haut sont corrects apparemment.

Merci pour ces précisions.

Jerome



Modifié 2 fois. Dernière modification le 10/03/12 11:41 par Jerome.
Luc
Re: module de chauffe mdlcnc
lundi 12 mars 2012 15:25:09
Bonjour Jérôme
Avec un fichier de découpe,
l'adaptateur en mode "contrôle chauffe par le PC", en cliquant sur découper,
en face de "mode de chauffe de la machine" j'ai l'inscription PC sur fond rouge si "chauffe en fonction du matériaux" est cochée (le fil reste froid)
et PC sur fond blanc si "chauffe réglée manuellement" est cochée (le fil chauffe plus ou moins selon le % indiqué, la machine et jedicut communiquent donc sur ce point)
Avec l'adaptateur en mode manuel, les inscriptions sont les mêmes : PC sur fond rouge ou blanc, mais le fil est chaud dans les deux cas
Dans les tests ci-dessus dans la fenêtre options la case "lire le mode de chauffe sur le port parallèle" est cochée.
Si je décoche cette case, dans la fenêtre latérale de déplacement manuel je peux cliquer sur "activer chauffe" (si elle est cochée je peux aussi) par contre dans la fenêtre option si je décoche "activer/désactiver le contrôle de la chauffe" je ne peux plus cliquer sur "activer chauffe" dans la fenêtre latérale, ce qui semble logique.
Merci de t'occuper de ce problème
Luc
Re: module de chauffe mdlcnc
mercredi 14 mars 2012 07:28:23
Salut,
Ta dernière phrase est correcte. Dans ton cas décoche "lire le mode de chauffe".

Après avoir décoché cette case peux tu refaire un test de chauffe dans la même fenêtre ? Jedicut affiche toujours -1 ou 1% ? Dans les options de Jedicut l'entrée chauffe est sur le pin 11 ?

Dans ton dernier message tu parles de "PC sur fond rouge". J'ai supprimé le rouge. Et j'ai remplacé le "Manuel" par "Externe".

Jerome
Seuls les utilisateurs enregistrés peuvent poster des messages dans ce forum.

Cliquez ici pour vous connecter



Aeropassion

Paris en photo | Design by Le Flaketou, création de site internet

Phorum