Aeropassion's homepage
Aeropassion's parteners :
Posted by Bruce Simpson 
Bruce Simpson
Direction signals not working properly
November 05, 2007 12:13AM
I've tried using Jedicut with several of the XP DLLs that come with the download and had little joy

With the MaxComXP DLL the steppers all move fine but the direction signals (3,5,7,9) are not changing on the parallel port so they only move in one direction.

With the VisualCNCXP DLL I can get X1, X2, Y1 all moving correctly (in both directions) but the direction signal (Pin 9 of the DB25) doesn't toggle to indicate direction.

I also find on the VisualCNC XP DLL that I can not vary the step-rate of the motors and they step exceedingly slowly (external timer is de-selected and I *can* vary the step speed on the MaxComXP DLL).

Any ideas?

Running Windows XP and I've tried two machines just to verify that there's not a hardware fault. This machine also runs the Linux-based EMC CNC software with no problems at all so I don't think it's hardware.

One clue -- both machines on which I installed JediCut came up with an error that said soemthing like "unable to connect with IO.sys but it is running" when first started. Is this normal? The error message has not reappeared.
Re: Direction signals not working properly
November 05, 2007 03:50PM

If your motors don't work in the both direction, you may not choose the right dll or you're board is not compatible with Jedicut 's dll. What kind of CNC board do you use ? Do you have a hobby cnc board, a MM2001 or a visual CNC board ?

I don't know why you see the message "unable to connect...". But if this message desappears it's good :p

Bruce Simpson
Re: Direction signals not working properly
November 06, 2007 01:04AM
I found the problem.

It was necessary to make a special cable for the controller I was using (to generate an "enable" signal) and there was a short-circuit in this cable that held the Y2 direction signal to ground.

That was fixed and now it works okay.
Re: Direction signals not working properly
November 06, 2007 11:18AM
Congratulation winking smiley

Steve Sainsbury
Re: Direction signals not working properly
December 16, 2007 11:45AM
Hello Jerome
I to have a direction problem. I am using a MM2001 board I have built up.
The four axis are working in one direction only, if I put a negative number like -10mm to travel in manual
the axis will not reverse. I have checked the parrallel port and get the correct step and direction to the pic chip for the four axis but have no reverse direction. I also tried FoamWorks with the same problem.
The speed of the axis is not slow like others have said on the forum.
Can you help with this problem.

Regards Steve
Re: Direction signals not working properly
December 17, 2007 01:15PM

If you use the right settings in Jedicut, It should be an electric problem :/

Sorry, only registered users may post in this forum.

Click here to login


Paris en photo | Design by Le Flaketou, création de site internet