Aeropassion's homepage
Aeropassion's parteners :
Posted by Daniel 
Daniel
Motors resonating
January 20, 2009 01:51PM
Hi
I have ben testing Jedicut for some days.
But I can not get the motors to run smooth.
I have ben testing manny different values/speeds and dll.
The travel is correct and speed seams ok.
The cnc card works fine with mach3.
Can it be the pin 17 engine on/off
In the manual for the board Pin 17 is marked as relay control.

Best Regards
Daniel
Snookie
Error
January 21, 2009 12:35AM
Hi there,

i am using the last beat version when i encountered this problem, but i got it also when i tried the last stable version.

When i use 2 dat files with the same amount of key-points, i gat an error when i try to preview the cut file, or when i try to cut the file.

Anyone has a clue, im am too new at this to say hat it's a bug so i'mm probably doing something wrong

Grtz,

ROb
COllen
Re: Motors resonating
January 21, 2009 09:20AM
Hi Daniel

I think I might have the same problem. See my post "Steppers are skipping steps" also posted today smiling smiley

Cutting distance and speed is OK but motors randomly skips/resonate within the same cut.

Please let me know if you find a solution.

Thanks
Collen
Re: Motors resonating
January 21, 2009 07:42PM
Daniel,

What board do you have ? Do you have any other program running on your computer ?

If you configure to high speed, your motors will lose steps. And if you don't heat enough when cutting, your motors will lose steps too...

Jerome
Daniel
Re: Motors resonating
January 22, 2009 10:53PM
I still can not get the motors to run smooth
I have been testing with mach 3
And everything works good (from 1 -2 mm/sec feed)
I can not find any proseses who wold interfer.
I have onely run jedicut with no load (no material )

Nb mm/pas = 0.005 (I have 1 mm pitch on leadscrews) 1,8deg 200 stepp motors
Cut speed =600 (with estimate 0.03 mm/sec)
fast =900 (with estimate 0.02 mm/sec) If I try 1400 (estimat = 0,01) and any number over that makes no diference.
Visualcnc xp.dll is jused.

One more thing.
My driver board runs mutch warmer ??
Driverboard
Daniel
Re: Motors resonating
January 22, 2009 11:19PM
Youtube motor running
Take a look
Re: Motors resonating
January 23, 2009 07:38PM
Daniel,

Do you check the option "synchronize with external timer" in Jedicut ?

I took a look at your video and I think your speed is too high.

Jerome
Daniel
Re: Motors resonating
January 25, 2009 11:32AM
Hi again

I have uploaded 5 videos
The one linked to in my last reply was det middel speed 500.(I have marked the videos with Nb mm/pas and speed)
If I make the engines go slower than move 1 http://www.youtube.com/watch?v=RHZ6At1Fv0o&feature=channel
They do run very hard .(video 4 http://www.youtube.com/watch?v=eqb0_AgwxNc )
And her are my settings video 5 http://www.youtube.com/watch?v=Vi3RkaDCnEM
Daniel
Re: Motors resonating
January 25, 2009 04:11PM
Hi again
I have uploaded some new videos http://www.youtube.com/profile?user=SomeCnc&view=videos
With different speeds.
Video 1 have 300in speed and the video in my last reply had speed 500 (video nr 2)
Video nr4 is a simulation run of an airfoil (Where it is almost posible to count the steps) and it viberates loudly.
Video nr5 is of my settings in jedicut.
Re: Motors resonating
January 26, 2009 09:24PM
Hi,

What kind of board is this ? A visual CNC one ? Are you sure of your pin configuration ?

Last question : do you have any documentation for the signal Jedicut have to send to your board ?

Jerome
Daniel
Re: Motors resonating
January 28, 2009 12:26PM
Re: Motors resonating
January 29, 2009 07:51PM
Daniel,

This documentation doesn't show the signal the software need to send... What Jedicut's dll do you try ?

Jerome
Daniel
Re: Motors resonating
February 02, 2009 12:03PM
I have used visualcncxp dll (It is the only dll that makes the motors go the correct distance.)

The cncboard works verry god with mach 3.
Do you know what signals thaht is putting out.
Re: Motors resonating
February 02, 2009 09:47PM
There is many ways to send signals on parallel port and if I don't know what signal Jedicut need to send, I can't do anything... Do you try MaxCom_XP.dll ?

Jerome



Edited 1 time(s). Last edit at 02/02/2009 09:47PM by Jerome.
Daniel
Re: Motors resonating
February 09, 2009 10:18PM
Hi again.

I tried MaxCom_XP.dll
But the scale did not match my innput .And the speed figures did not make sense.
I tried many different combinations. But the motors was worse than with visual xp (there the scale was right)

I have read and tested some more .And jused a parrallelport monitor.

And as far as I can understand :

My driverboard needs the folloving signals.

X axis one direction = constant activ low on pin 3 and step pulses (activ low )on pin 2
the oter direction = no signal on pin 3 and step pulses (activ low )on pin 2
Y axis one direction = constant activ low on pin 5 and step pulses (activ low )on pin 4
Z axis one direction = constant activ low on pin 7 and step pulses (activ low )on pin 6
A axis one direction = constant activ low on pin 9 and step pulses (activ low )on pin 8

Do this make sence ??
I hope so
Daniel
Re: Motors resonating
February 10, 2009 12:30PM
My last post came out wrong.
I misunderstood the Usermanual for the board .

My driverboard needs the folloving signals.

X axis one direction = constant activ high on pin 3 and step pulses (activ high )on pin 2
the oter direction = no signal on pin 3 and step pulses (activ high)on pin 2
Y axis one direction = constant activ high on pin 5 and step pulses (activ high)on pin 4
the oter direction = no signal on pin 5 and step pulses (activ high)on pin 4
Z axis one direction = constant activ high on pin 7 and step pulses (activ high )on pin 6
the oter direction = no signal on pin 7 and step pulses (activ high)on pin 6
A axis one direction = constant activ high on pin 9 and step pulses (activ high )on pin 8
the oter direction = no signal on pin 9 and step pulses (activ high)on pin 8

Sorry
Re: Motors resonating
February 13, 2009 08:11PM
This seems to be compatible with CncNet dll. Do you try it ?

Jerome
Re: Motors resonating
February 13, 2009 08:33PM
Good idea this openly setup in Engine Setup panel (Step Low Active on/off). This need change My Controller (H2 PCcool smiley also (use low active Step signal).

www.hobbycnc.hu
Sorry, only registered users may post in this forum.

Click here to login



Aeropassion

Paris en photo | Design by Le Flaketou, création de site internet

Phorum