Aeropassion's homepage
Aeropassion's parteners :
Posted by Collen 
Collen
Steppers are skipping steps
January 21, 2009 08:44AM
Hi Jerome

Thanks for all your effort and time in creating such an amazing program. I purchased the HobbyCNC Foam Pro board with an 8kHz timer.
I finally got all my motors to run but sometimes find that they are skipping steps.
My configuration is:
CNCNet98.dll as I'm running on Windows 98SE
I have selected the Syncronize with External Timer and set a 8000Hz value. (as my board has its own timer)
Nb mm/pas = 0.005
Cut Speed = 18 thus Est mm/s = 2
Fast Speed = 15 thus Est mm/s = 2.35

When entering a cutting distance for example 30mm my CNC moves exactly 30mm, thus I know my Nb mm/pas is set correct. I also don't have a problem with speed using above setup. My only problem is sometimes I can see and hear the motors skipping some steps. Like I said this is a very random occurance as sometimes they run very smooth and sometimes not or they will start smooth then skip some steps and then all of a sudden run smooth again all in the same cut! Any idea as to what the problem can be?

Thanks
Collen
Re: Steppers are skipping steps
January 21, 2009 07:35PM
Hello,

When your motor lose steps, is there any other program running on your computer like antivirus scanning files ? Are you losing steps when you are cutting ? If you don't heat enough you can also lose step...

Jerome
snookie
Re: Steppers are skipping steps
January 22, 2009 12:52AM
I think i know what he means with hearing the lost steps.

I hear it too sometimes, but it is very minor loss. ( 1 step for me = 0,00625mm)
But it happens in GMFC too.

I think it is a app running in the background.

When i start moving my mouse around it gets worse.

Maybe my laptop is a little too old for this, but it has a nice LPT port, and my new one hasn´t.

Grtz,

snookie
Collen
Re: Steppers are skipping steps
January 22, 2009 08:32AM
Hi Guys

Yes, its definitely 'something' running in the background....Last night I noticed that when I move my mouse I could hear the resonance in the motors. Also in Jedicut's Cut in Progress bar, as soon as a new progress bar is added you also notice this.

I've set my LPT port mode to both EPP & ECP and no difference. Problem seem to be processing that somehow interrupts to the LPT port.
Any idea how we can set the printer port dedicated for Jedicut?....I'm afraid I don't have enough knowledge on port interrupt requests and address resources confused smiley

Thanks
Collen
Re: Steppers are skipping steps
January 22, 2009 09:14AM
Hello,

Jedicut works well on old computer. Just let your mouse sleep a little when you're cutting :p

You can may be take a look at the list of the programm running on background. Maybe you can desactivate something ? An other idea : sometimes, if you try some other CNC program, they install driver which block Jedicut...

Jerome
Frank
Re: Steppers are skipping steps
March 25, 2009 04:24PM
Hello,
I have the same problem. I tested the driver VisualCNC and CNCNet with my CNC Board which is compatible to the board of Ostermann (comman in germany). It uses the L298 chip and support half and full step. Without cuting I hear that the motor irregulary skip steps. Which communication protokoll ist used from the drivers? I would like to contact the dealer to ask about the communication protcol from the card. If I need another protocol, is it possible to get a new .dll?
Best regards
Frank

Jerome, thank you for the nice software, which is exact that I need for developing new aeroplanes.
Re: Steppers are skipping steps
March 25, 2009 08:13PM
Hi Frank !

All is possible ! :p As soon as you receive the protocol communication, leave a message on this forum, and I'll take a look at it winking smiley

Do you know what software works well with this CNC board ?

Jerome
collen
Re: Steppers are skipping steps
March 26, 2009 10:40AM
Hi Frank

The problem I have is definitely caused by interrupt requests on the printer port! It's not that big a problem for me and I don't really see any errors in my cuts although I mainly cut very small parts - Maybe on bigger cuts you might notice something?
Frank
Re: Steppers are skipping steps
March 26, 2009 10:41AM
Dear Jerome,
thank you for your quick response. The dealer mentioned the software PC-NC or WINPC-NC on his homepage (Download section). On the follwing link are more information and in the "Online shop" you can find the 4 channel board (SM44PCV5) I use. Possibly more jedicut users are interested in the board, because the price is 111,50 Euro for the ready to use board with parallel port cable.
Best regards
Frank

http://www.gwr-elektronik.de/start.html
http://shop.strato.de/epages/61125483.sf/de_DE/?ObjectPath=/Shops/61125483/Products/%22SM44PCV5.1/RK2%22
Under "Beschreibung als PDF" you can download the instruction manual in german
Frank
Re: Steppers are skipping steps
March 26, 2009 11:05AM
Dear Jerome,
according to my topic a few minutes before, I have some additional information. I just talked to the developer of the board. He said that the board works fine with a pulse duration (pulse width) over 10us in the communicatin protocol. Under 10us it´s not stable. Does this information help?
Best regards
Frank
Re: Steppers are skipping steps
March 26, 2009 08:37PM
I read the pdf with google translate and I don't find chronogram or something like that. Can you ask the developper ?

Jerome
Frank
Re: Steppers are skipping steps
March 26, 2009 09:03PM
Dear Jerome,
the developer said he knows from other users, that the have some time problems with software which sends the signals faster than 10us each signal. That means for example the high signal must be given from the software >=10us before ther next signal is sended. In the knew version of the board they changed the pulse/signal transmitter (optokoppler) from PC817 to a faster one (PC847) to avoid this problems. But this will not help me with the old version :-(.
Best regards
Frank
Re: Steppers are skipping steps
March 26, 2009 10:15PM
What is the external timer frequency ?

Jerome



Edited 1 time(s). Last edit at 03/26/2009 10:16PM by Jerome.
Frank
Re: Steppers are skipping steps
March 27, 2009 08:43AM
I don´t use an external timer. If I understand the support from GWR right, there isn´t a special protokol. The direction is conrolled by a high or low signal on a dedicated pin for each motor of the parallel port. For the motor rotation one impulse on on a dedicated pin for each motor is one step. But the pulse duration/pulse width (high or low) should be longer (>10us).
Best regards
Frank
Re: Steppers are skipping steps
March 27, 2009 08:33PM
Do you try MaxCom_XP.dll ?

Jerome
Frank
Re: Steppers are skipping steps
March 28, 2009 02:49PM
I tested the MaxCom_XP.dll with manual movement. The motor makes a very slow movement. If I increased the cutting speed, the movement was faster. But the way of manaual movement was only about 1mm instead of 50mm I typed in. The NB mm / pas value is right configured.
I talked to GWR again. They will send me a new PC847 optokoppler chip next week. Hopefully the problem is solved than.
Best regards
Frank
Re: Steppers are skipping steps
March 29, 2009 12:56PM
Quote
Frank
But the way of manaual movement was only about 1mm instead of 50mm I typed in. The NB mm / pas value is right configured.

Do you see your motors lost steps ?

Jerome
Frank
Re: Steppers are skipping steps
March 29, 2009 03:15PM
With MaxCom_XP.dll the motor lost no steps.
Frank
Re: Steppers are skipping steps
March 31, 2009 08:34PM
So, you don't still have problem with your CNC board, do you ?

Jerome
Frank
Re: Steppers are skipping steps
April 01, 2009 09:47PM
With the MaxCom_XP.dll the motor movement is not correct. It moves only about 1mm instead of 50mm. If I got the new optokoppler chip I test it and give you a status.
Frank
Frank
Re: Steppers are skipping steps
April 15, 2009 08:54PM
Hello Jerome,
I got the new optokopplers, but they don´t change the skipping. I will lend me an oszilloskope to check the signal from the parallel port of my laptop and Desktop PC.
Did you receive my email with the drawing of the recommended signals (impulse width ...) and do have any idea according to the drivers?
Best regards
Frank
Re: Steppers are skipping steps
April 22, 2009 10:59PM
Hi !

I received your emails but actually, I don't know how to control your CNC board engine... I need time to work on it, sorry winking smiley

Jerome



Edited 1 time(s). Last edit at 04/22/2009 11:00PM by Jerome.
Torsten
Re: Steppers are skipping steps
June 15, 2009 11:39AM
Hi Jerome,
thank you for your nice software jedicut.
It have all goodness for producing comfortable foam models.
Since 2 weeks I have tested it with my foamcutter projekt. And now I have some questions.
My system is WIN XP home 1,7Ghz 512Mb ram and the 4 stepper motors are on driver boards (2x2channel) from the

same Customer "GWR" like Frank`s boards.
I have stopped the antiviral scanner and the W-Lan on my notebook and now your software working.
The Steppers working only with the XP_dll`s (thats normal :-)) but only not with the maxcom_Xp.dll(there it must be

programm a different way to drive the steppers)
By the other Visualcnc and CNCnet.dll i have for fast movement 100000 and for low 10000000 the steps / mm is

0.0075 (200 steps/turn and M10 =1,5mm).
So the steppers drive the right way (exactly) but only, (so I mean) very slow if I reduce under 100000 like 50000 the

motors lose steps or don`t move.
As an example 700mm movement is going in 15min (by fast motion) I think it`s right to cut but not for fast drive
The foamworks trial version move very faster, but your software is funktionally better I think so.
Can you give me an answer please what the problem is?
Is it better to have an external timer?

Thank you for your work

glad to hear from you

Torsten
Re: Steppers are skipping steps
July 01, 2009 07:07PM
Hello,

If you find a good speed setting in order to cut, it's enough winking smiley

If you find a speed setting where motor lose steps, I'm sorry. I don't know how I can do. Maybe the board is not full CnCNet compatible. What kind of board do you use ?

It's better to use an external timer but it's not necessary winking smiley

Jerome
Sorry, only registered users may post in this forum.

Click here to login



Aeropassion

Paris en photo | Design by Le Flaketou, création de site internet

Phorum