Aeropassion's homepage
Aeropassion's parteners :
Posted by ZbigPL 
ZbigPL
ENABLE - Lo
May 17, 2009 02:27PM
Hi, Jerome
My board works with signal ENABLE = 0.
Can You help me?
Configuration:
PC Toshiba Satellite Pro 4200 with W98 >grinning smiley<, but with LPT!
CNC SPARTIA by Papy Kilowatt (in progress)
board with Toshiba TA8435H.

With regards, ZbigPL
Re: ENABLE - Lo
May 17, 2009 07:41PM
Hi,

I'm sorry, I don't understand your problem sad smiley

Jerome
ZbigPL
Re: ENABLE - Lo
May 17, 2009 10:32PM
My englisch is poor, so my sentences are shorter then ideas.
Jedicut send signal ENABLE =1 (pin 17). My drivers are activated by signal ENABLE = 0.
I had to install inverter (75LS05) at pin 17, but software solutions would be better.

ZbigPL
Re: ENABLE - Lo
May 17, 2009 10:50PM
What kind of CNC board do you have ?

Give me your e-mail adress, I'll send to you special dll you will try.

Jerome
Re: ENABLE - Lo
May 18, 2009 01:00AM
CNC board is self-made with Toshiba TA8435H drivers.
With inverter motor works.
zcz@epf.pl
ZbigPL
Re: ENABLE - Lo
May 18, 2009 07:50AM
With inverter, motor works. But what dll do you use ?

Jerome
Re: ENABLE - Lo
May 18, 2009 12:23PM
Bonjour!
CncNet98 and VisualCNC

ZbigPL

ZbigPL
Re: ENABLE - Lo
May 18, 2009 08:31PM
Hi !

You have an e-mail winking smiley

Jerome
Re: ENABLE - Lo
May 18, 2009 09:35PM
Merci beaucoup, Jerome!
Both dlls work perfect without inverter.

ZbigPL
Re: ENABLE - Lo
May 27, 2009 12:11AM
Hi!
Once more - configuration:
Windows 98 SE
Board (without timer) input signals (TTL):
ENABLE - active Low
CLK (min 1 µs)
DIR

Using CncNet98.dll or VisualCNC.dll rotational speed is constant and low (about 2,5 turns/10sec) independent on "Speed". I can control direction of rotation.

MaxCom.dll do not work (Win98?).

With MaxCom_XP.dll(?!) I can control the rotational speed ("Speed">80000) but motor not react on signal DIR.
Manualy conecting line DIR to 0V or 5V changes direction.
Voltage levels (0,24V/4,24V) on line DIR are identical with CncNet98.dll and MaxCom_XP.dll.
Do you have some solutions?

ZbigPL
Re: ENABLE - Lo
May 29, 2009 05:14PM
> With MaxCom_XP.dll(?!) I can control the rotational speed ("Speed">80000) but motor not react on signal DIR.
> Manualy conecting line DIR to 0V or 5V changes direction.

After inserting capacitor 0,1 µF on input DIR of motor driver I can control direction (MaxCom_XP).
I think you know what happened.
Re: ENABLE - Lo
May 30, 2009 09:38PM
Hi,

All dll are differents because there are many solutions for the signal. It depends on the CNC board designer choices.

Can you describe the signals DIR and step that your board is waiting for ?

Jerome
Re: ENABLE - Lo
June 02, 2009 11:55PM
Hi
Today I test driver-stepper whith simple multivibrator.
Settings:
ENABLE -> GND
DIR -> GND
CLK -> multivibrator output
Motor (1,8 deg/step) goes to about 1500 Hz with 1/1 stepping and 6kHz with 1/4 stepping.
I can set 1/1, 1/2, 1/4 and 1/8 stepping.
Reconnecting DIR between GND and 5V changes the direction of motor.
It looks very easy but we have saying: "Devil seats among details".

Best regards

ZbigPL
Re: ENABLE - Lo
June 13, 2009 10:56AM
Hi !

Is everything all right ?

Jerome
Re: ENABLE - Lo
June 27, 2009 02:59PM
Hi, Jerome!
I was on holiday without Internet.
Currently my machine is ready to work.
I succesfully tested it with Foamworks but I hope that I'll can work with Your program.
Machine works too slowly with CncNet98.dll or VisualCNC.dll.
With MaxCom_XP.dll (ENABLE inverted) I can control the rotational speed but not direction.
I sent You driver's datasheet with signal description. Only limitations is CLK > 1 microsec.
It looks that You have to "glue" control the rotational speed from CncNet98.dll and direction control from MaxCom_XP.dllwinking smiley.

ZbigPL
Attachments:
open | download - Logic.jpg (51.6 KB)
Re: ENABLE - Lo
July 01, 2009 07:02PM
Hello,

It's not so easy winking smiley I'll take a look on it soon winking smiley

Jerome
Re: ENABLE - Lo
July 02, 2009 12:04PM
Hi
I believe in youthumbs up!
Please, remember about inverted ENABLE.

ZbigPL
Re: ENABLE - Lo
July 05, 2009 11:12AM
I take a look at your driver datasheet and I think it works like CnCNet.dll.

Can you post the speed setting you use with both dll ?

Jerome
Re: ENABLE - Lo
July 09, 2009 03:52PM
Hi, Jerome!
Test results with modyfied (inverted ENABLE) CNCNET98:
"Speed": from 1 to 40.000 -> Motor: about 1 turn/s (lost single steps)
"Speed": from 50.000 to 1.100.000 -> Motor: about 1 turn/s no reaction on "Speed"
"Speed": 1.200.000 -> about 0,5 turn/s
"Speed": 5.000.000 -> about 0,2 turn/s
Settings:
step 1/1
200 steps/1 turn

Max motor speed is a little to slow.
I can't test MaxCom_XP.dll without inverter, but I remember "speed">80000.

Zbig



Edited 1 time(s). Last edit at 07/09/2009 03:53PM by ZbigPL.
Re: ENABLE - Lo
July 09, 2009 07:59PM
If you find speed value where you lose step, I don't know what I can do... If you have any idea...

0,5 turns/s isn't enough ?

Jerome
Re: ENABLE - Lo
July 10, 2009 03:55PM
confused smileyThe machine opportunities are about 5-6 turns/s (CLK = 1500 Hz) so I hope work "Fast" about 4-5 turns/s and "Slow" 2 turns/s (1 turn = 1 mm).
hot smiley I'm having an idea: I can take signal CLK, for example 1,5 kHz, from rectangular wave generator and DIR, ENABLE from Jedicut. What You think about?

Best regards
Re: ENABLE - Lo
July 13, 2009 11:11AM
Sorry!
Ideas with generator is not wise:o. I wrote it befor I thought about.

ZbigPL
pieter
Re: board type - compatibility
August 03, 2009 06:24PM
Hi Jerome

My machine uses Probotix boards. Will Jedicut work?

Regards
Pieter
Re: board type - compatibility
August 03, 2009 07:25PM
Hello,

Without more details ? I don't know... But you can try ! winking smiley

Jerome
Sorry, only registered users may post in this forum.

Click here to login



Aeropassion

Paris en photo | Design by Le Flaketou, création de site internet

Phorum