Aeropassion's homepage
Aeropassion's parteners :
Posted by Laubi 
The stepper ist allways to slow
August 04, 2011 10:54PM
Hallo Jerome,

I have the stepper board with L297/L298. My PC ist an older one with Windows XP SP2.

After learnig by try and error the motors work nearly satisfied, but to slow. For one revolution with 200 steps (=1,25 mm) I need 8 seconds.

My oscilloscop shows me 40 ms from step to step. Can you give me a tip?

Danke Laubi
Re: The stepper ist allways to slow
August 05, 2011 06:42PM
Hello !

What speed values did you set up ? Do you use an external timer ?

Jerome
Re: The stepper ist allways to slow
August 06, 2011 06:40PM
Hello Jerome

I tried profil s1020.dat and others

Kommunication:
Motor not synchronisied, no externer timer

Way (mm) per Step i.e. 0,05 (I tried also from 0,1 to 0,01) all Motors
Feed (Vorschub) 500 on normal and quickly for all Motors

hot wire = 400 mm
x-axis (mm) =1000

Modify all values brought no change of speed


Another:
Vertical synchronous movement does'nt get out of polystyrene


Thanks for helping

Laubi
Re: The stepper ist allways to slow
August 08, 2011 11:33AM
Hello

without external timer your speed value are not normal. Do you have a jumper on your cnc board to select 1/2, 1/4, 1/8 step mode ?

I don't understand your last question.

Jerome
Re: The stepper ist allways to slow
August 08, 2011 10:56PM
Hallo,

there is no such a jumper. I attach a file. This is the well known Stepper Driver with IC' L297 and L298. There is extra IC3 which allows to drive the stepper without CLK Signal. Q1 to Q7 in K1 together with P2 gives rotation speeds. GATE must be high.

I use only Signal ENABLE, CLK and CW/CCW from the PC

SYNC is used for synchronisation with other boards.

Because the other question i will send you a plot

thanks
laubi
Attachments:
open | download - Schrittmotor 001.jpg (133.6 KB)
Re: The stepper ist allways to slow
August 09, 2011 06:09PM
Hello,

Did you get the attached file at last y
Sorry I misunderstand your question because a jumper. There is an internal oscillator. With SYNC you can synchronice with other boards. The CLOCK is then output to PC which can read the number of steps. With IC3 and K1 you can divide the number of steps controlled by P2 , R11 and C1.

With GATE low the IC3 is locked.

But I mean the PC has to controll the step rate and not opposite ?

MODE controls the magnetic flow in motor (phase chopping).

I can send you the description but only in Deutsch!

Laubi
Attachments:
open | download - Plot.jpg (120.8 KB)
Re: The stepper ist allways to slow
August 09, 2011 08:56PM
Hello Jerome

I have good news: Allways I used VisualCNC_XP. But with MaxCom_XP I got a good speed. Code Emplanture is 2000 and the plot shows a lengs of 208 mm. The X-speed is 3 mm/s.

Nb mm/pas is 0,03

Vitess de Decupe and Rapide is 100 000 and no timer externe used
I can not understand that this may be in mm

In Cycle de decoupe I have no Verticale and Horizontale goes straight ahead through the profil and not outside. The Cycle de decoupe is like your examble.

Laubi
Re: The stepper ist allways to slow
August 10, 2011 10:55AM
Good job!

Yes you can send me the description of your CNC board even if it's in english winking smiley Thanks !

Jerome
Re: The stepper ist allways to slow
August 10, 2011 08:29PM
Hallo,
I tried to send all descriptions and the layout as attachment. But the other files are to big.

If you give me your eMail, I will send all to you. Included a board-layout written in Sprint-Layout 5. You may that print to film to take it on Cu-board. So you have it 1:1
Sprint-Layout.exe you can download from Internet.

Laubi
Attachments:
open | download - Stepper2.jpg (133.8 KB)
Re: The stepper ist allways to slow
August 11, 2011 10:01AM
Hello

Click on my name on this forum, you will see my email winking smiley

Thanks.

Jerome
Re: The stepper ist allways to slow
August 16, 2011 10:34PM
Hallo Jerome,

With try and error I got an answer of my Problem:
If asked to give a data in a field, one is asked for mm. But you must enter 1/10 mm. Examble: The profil shall have a lenght of 200 mm, you have to enter 2000 mm.

At the window with separat moved X1,X2,Y1,Y2 it seems to be exchanged slow and fast ???

The main problem is the absent of descriptions what entering of a variable effects.

Did you get my e-Mail?

Sincerly Laubi
Re: The stepper ist allways to slow
August 18, 2011 10:57AM
hello

I received your mail.

There is no exchange in speed values but I will verify again winking smiley

What do you use in "mm/step" value in Jedicut settings ? With the problem you described, you should multiply this values by 10.

Jerome
Re: The stepper ist allways to slow
September 13, 2011 05:01PM
Hallo Jerome
I tried to plot a profil with Holm. The round profils are ok. But not the rectangular, see attachment.
have you an idee?

Laubi
Attachments:
open | download - Plot Profil.jpg (59.7 KB)
Re: The stepper ist allways to slow
September 22, 2011 05:27AM
Hi,

I answer your email. Can you post your jdc file ?

Jerome
Sorry, only registered users may post in this forum.

Click here to login



Aeropassion

Paris en photo | Design by Le Flaketou, création de site internet

Phorum